The Android community has come to use Rx pretty heavily but surprisingly there hasn't been any one convention that's won, when it comes to how we name our functions that return Observables.
userUpdates() ? In this mini-episode dutifully does the yak-shaving for you and discusses what some options are and what the community has been gravitating towards.
// option 1 fun getUser(): Single // yuck // option 2 fun user(): Observable // but what does this mean? // option 3 fun user(): Single fun userUpdates(): Observable // or fun userStream(): Observable // this is looking good // option 4 (upday style) fun userOnce(): Single fun userStream(): Observable fun userOnceAndStream(): Observable
Stay tuned for a future episode, where we discuss more details and more complicated cases to handle (like emitting a list of user, policies for fetching the first user as quickly as possible etc.).